If you’re running Apache, you probably need to install the latest version, because there’s a big exploitable hole in all but the most recent versions of Apache 1.3 and Apache 2.0 on all platforms.