The other day I was going to write this cool post about how I’m trying to speed up the performance of Movable Type using FastCGI for the Perl bits and eAccelerator for the PHP bits. The nice thing about FreeBSD is that both packages were really, really easy to install. I can’t tell how much faster they’ve made things, but they seem to have improved the performance situation at least a little bit. (I think that part of my problem may be that the blog has over 7900 entries, and that just makes things a bit slow.)
Anyway, today I started getting email from Postfix about it rejecting incoming mail because I was out of drive space. So I logged into the server and found that the var partition was indeed 99% full. At first I thought it was because my port installs weren’t cleaning up after themselves, but I quickly discovered that the culprit was a 1.1 gigabyte Apache error log file. It turns out that when I installed eAccelerator I didn’t configure it properly, so it was running in debug mode, which meant that every time anyone accessed a PHP page on the site, eAccelerator added a line to the error log. Soon thereafter, full partition.
I’m beginning to feel like every time I touch anything, I have planted the seeds for a future outage.
The more systems administration tasks I perform, the more I understand why systems administrators tend to hate programmers.